Probleme mit der Suche bei Excel

Seiten: 1
mazepan
Verfasst am: 19.08.2011 um: 14:03 Uhr
 
Cw Guru
King
Beiträge: 603
SPAM:
1% Spam
Hallo,

ich habe in einer sehr großen Exceltabelle eine Suhce intergiert.
Es gibt nur einen Fehler, wenn ich das Wort gefunden habe, es dieses Wort kein zweites Mal gibt  und "Ja" drücke, gibt es ein Problem.
Wenn ich OK drücke oder der Suchebgriff nicht gefunden wird ist auch alles OK.

Hier mal der Code:


'StandardModule: basMain
'über mehrere Tabellenblätter suchen:
Sub MultiSeek()
  Dim wks As Worksheet
  Dim rng As Range
  Dim sAddress As String, sFind As String
  sFind = InputBox("gesuchtes Wort eingeben:", "Suchen", "Suchbegriff")
  For Each wks In Worksheets
      Set rng = wks.Cells.Find( _
        what:=sFind, _
        lookat:=xlWhole, _
        LookIn:=xlFormulas)
        If Not rng Is Nothing Then
            sAddress = rng.Address
            Do
              Application.Goto rng, True
              If MsgBox( _
                  prompt:="Weiter", _
                  Buttons:=vbYesNo + vbQuestion _
                  ) = vbNo Then Exit Sub
              Set rng = Cells.FindNext(after:=ActiveCell)
              If rng.Address = sAddress Then Exit Do
            Loop
        End If
    Next wks
    MsgBox prompt:="Nichts gefunden!"
End Sub

Hier die Fehlermeldung:

Laufzeitfehler `97´!
Objekltvariable oder With-Blockvariable nicht festgelegt


Mein Wissen dafür ist nicht so groß und daher komme ich nicht weiter.
Wo liegt der Fehler, wer kann mir bitte helfen.

Danke

MfG
Mazepan




Meine HP




Letzte Änderung am: 19.08.2011 um:14:05 Uhr durch: mazepan
 

Thema Nr. 34798 in folgendes Forum verschieben:
 


 
Seiten: 1

Folgende User sind hier gerade aktiv:
-

ANZEIGE