CwCity Board >>> Allgemeines >>> CwCity.de >>> Ankündigung: Umstellung PHP 5.4
Ankündigung: Umstellung PHP 5.4

Seiten: << 1, 2, 3
chrwhm
Verfasst am: 28.10.2013 um: 11:25 Uhr
 
Globaler Moderator
0
Beiträge: 6088
SPAM:
0% Spam
Mahlzeit,

hab das Thema auch grad in der Firma, daher die Frage: Wäre ein Update auf PHP 5.5 nicht auch gleich sinnvoll? Dann spart man sich später diesen Schritt - und so krasse Veränderungen gibts dann auch nicht zwischen 5.4 und 5.5... Außer, dass mysql_connect & co endlich offiziell als deprecated markiert werden ;-)

lg



www.laptop-kaffee.de

"Normalised data is for sissies."
(Cal Henderson, chief software architect of flickr)

 

consider
Verfasst am: 28.10.2013 um: 11:34 Uhr
 
Dr. CwCity.de
Community God
Beiträge: 7217
SPAM:
0% Spam
Werden denn mit 5.5 keine Funktionen und Features entfernt? Ich finde nichts. Auch sonst nichts wildes an Inkompatibilitäten, bei denen ein Zwischenschritt zur Vorbereitung wichtig wäre.

Von da her...warum eigentlich nicht?

PS. Komischerweise werden die da

http://www.php.net/manual/en/migration54.deprecated.php

M
it 5.4 nicht entfernt. 



Letzte Änderung am: 28.10.2013 um: 11:40 Uhr durch: consider
 

Ratgeber
Verfasst am: 29.10.2013 um: 01:07 Uhr
 
Dr. CwCity.de
Community God
Beiträge: 10010
SPAM:
0% Spam
Beim Umstieg auf PHP 5,5 muss ich dazu raten, das Webtool WBBLite 2.0.1 offline zu nehmen... oder zumindestens ein Update (also nicht Upgrade auf 2.1.x) einzuspielen.
Dieses alte WBBLite 2.0.x crasht, sobald es mit PHP 5.5 auch nur "in Berührung kommt"... wenn es kein automatisches Update mitbekommen hat.

Das ist jetzt ein reiner Erfahrungswert.
Habe es seit 2012 bei einem anderen Hoster im Einsatz gehabt, der aber kein fsockopen für Updates ermöglicht. Er hat das PHP 5.5 schon seit einiger Zeit im Einsatz und seitdem war das Forensystem faktisch nicht mehr benutzbar.
Das Problem könnte also schon direkt bei der Installation des Webtoools auftreten. Der Hinweis ist also gerade für Einsteiger wichtig und nützlich, die mit diesem Tool die ersten Wirths ausgeben, die sie sich erst später erschreiben müssen.

Andere Systeme sind deshalb nicht betroffen, weil da man dort ja jedes Update (als User) nachträglich manuell einpflegen kann.



 
Ratgeber---Forum.de ---- Partnerseiten ------ Halle der Ehre ----- zum Forum ---- Ratgeber---Forum.Net ----- Das Ende des Internets
----> Interessante andere Seiten --> Toromino.de 


 

spidercham
Verfasst am: 21.11.2013 um: 23:46 Uhr
 
Cw Guru
King
Beiträge: 602
SPAM:
0% Spam
  
Zitat von chrwhm

Mahlzeit,

hab das Thema auch grad in der Firma, daher die Frage: Wäre ein Update auf PHP 5.5 nicht auch gleich sinnvoll? Dann spart man sich später diesen Schritt


Hallo zusammen,

diesen Schritt würde ich mir sowieso sparen. Wie du selbst sagst, ist der Unterschied nicht groß. Das Updaten auf PHP 5.5 ist in erster Linie überhaupt nicht notwendig. (Und würd es vermutlich auch nie sein)

Im Gegenteil. Es verursacht lediglich Probleme von der Art, die man hat wenn man das ganze nochmal Updaten muss. Ratgeber hat es schon ganz treffend formuliert.

Wir sollten die Umstellung auf PHP 5.4 wagen, und an das PHP 5.5 garnicht erst denken. Ich glaube, dass es sich nicht durchsetzen wird.

Mit freundlichen Grüßen
Spider

"Toleranz ist die letzte Tugend einer untergehenden Gesellschaft"
(Aristoteles)
"Sag ja zur Australischen Migrationspolitik"
Verschwiegene Kosten der Zuwanderung

 

Verfasst am: 22.11.2013 um: 10:02 Uhr
 

  
Zitat von schulle
Hallo liebe CwCity-User,

die letzte Version von PHP 5.3 ist bereits erschienen und wird nicht mehr weiterentwickelt. Aus diesem Grund wird auf CwCity innerhalb der nächsten Wochen ein Update von PHP 5.3 auf die Version 5.4 durchgeführt. Ich werde die Umstellung wenige Tage vorher noch einmal ankündigen. Ich werde hier auch die wichtigsten Fragen nach und nach updaten:

Was ändert sich für mich?
Solltest Du eine aktuelle Version eines CMS verwenden, musst Du nichts tun. Bei selbst programmierten Scripten ist es empfehlenswert, diese auf die Kombatibilität zu überprüfen. Mehr dazu findet man hier: 
php.net/manual/de/migration54.php


Da ich leider in diesen Dingen keine Ahnung habe nun folgende Frage:
Ich habe meine Homepage sg04bn.cwsurf.de/  mit "NetObjects Fusion 7,5" erstellt und diese in/auf Ihrem Server übertragen. Muss ich da was ändern und was genau.
Danke schon mal im voraus.


 

kethost
Verfasst am: 14.03.2014 um: 17:44 Uhr
 
Cw Insider
Wirths Sammler
Beiträge: 219
SPAM:
0% Spam
Ich find es super, dass immer die Aktuellen Versionen drauf sind!

Meine Web-Projekte:

Homepage

Team Autismus
 

bw5rws
Verfasst am: 15.03.2014 um: 11:51 Uhr
 
Cw Guru
King
Beiträge: 945
SPAM:
0% Spam
Es ist nicht immer die Aktuelle Version.
Ich glaube das Update wurde nicht gemacht.
Schulle haette sich sonst gemeldet.
Ist aber auch gut dann muss ich wenigstens nichts aendern.

 

Verfasst am: 15.03.2014 um: 13:15 Uhr
 

Vielleicht kommt das Update ja im Laufe des Tages noch.

 

bw5rws
Verfasst am: 15.03.2014 um: 13:40 Uhr
 
Cw Guru
King
Beiträge: 945
SPAM:
0% Spam
Das glaube ich nicht.
Die Ankuendigung ist von November 2013.

 

bzstyle
Verfasst am: 13.08.2015 um: 18:43 Uhr
 
Cw Posting Dude
Poster Teufel
Beiträge: 97
SPAM:
0% Spam
Hallo,
ich möchte dieses Thema wieder zum Leben erwecken, denn CwCity ist immer noch (zumindest auf u02) auf PHP 5.3.27. Bereits vor einem Jahr ist die letzte 5.3.29 rausgekommen, für die es keine Fixes mehr gibt.

Eine Umstellung auf mindestens 5.4 ist also dringend notwendig, auch um die Unterstützung zu aktuellen Tools zu gewährleisten!
Wann kann man mit einer Umstellung rechnen?

Danke. bis bald.

 

 
Seiten: << 1, 2, 3

Folgende User sind hier gerade aktiv:
-

ANZEIGE