CwCity Board >>> Allgemeines >>> CwCity.de >>> Ankündigung: Umstellung PHP 5.4
Ankündigung: Umstellung PHP 5.4

Seiten: 1, 2, 3 >>
schulle
Verfasst am: 17.10.2013 um: 06:19 Uhr
 
System Admin
Admin
Beiträge: 5106
SPAM:
0% Spam
Hallo liebe CwCity-User,

die letzte Version von PHP 5.3 ist bereits erschienen und wird nicht mehr weiterentwickelt. Aus diesem Grund wird auf CwCity innerhalb der nächsten Wochen ein Update von PHP 5.3 auf die Version 5.4 durchgeführt. Ich werde die Umstellung wenige Tage vorher noch einmal ankündigen. Ich werde hier auch die wichtigsten Fragen nach und nach updaten:

Was ändert sich für mich?
Solltest Du eine aktuelle Version eines CMS verwenden, musst Du nichts tun. Bei selbst programmierten Scripten ist es empfehlenswert, diese auf die Kombatibilität zu überprüfen. Mehr dazu findet man hier: 
php.net/manual/de/migration54.php

Mit freundlichen Grüßen

Support & Management


Schulle

Urlaubs Schnäppchen bei Urlaubstracker




Jetzt neu: CwCity auf Facebook

 



Studentenjobs


Support:
support[ a ]cwcity.de


Letzte Änderung am: 30.10.2014 um:17:15 Uhr durch: schulle
 



blackphantom
Verfasst am: 17.10.2013 um: 14:42 Uhr
 
Dr. CwCity.de
Community God
Beiträge: 3017
SPAM:
0% Spam
Hi,

na das ist ja super zu hören. Ich finde PHP 5.4 echt geil. Die neue Shorthand-Syntax für Arrays ist auch geil. Des Weiteren gibt es für OOP sogenannte "Traits". Da könnt ihr ja selbst mal googlen. Scheint ne nette Hilfe zu sein aber ein richtiges Anwendungsbeispiel dafür finde ich noch nicht.

MFG BlackY =)

 

consider
Verfasst am: 17.10.2013 um: 15:18 Uhr
 
Dr. CwCity.de
Community God
Beiträge: 7217
SPAM:
0% Spam
  
Zitat von blackphantom
Hi,

na das ist ja super zu hören. Ich finde PHP 5.4 echt geil. Die neue Shorthand-Syntax für Arrays ist auch geil. Des Weiteren gibt es für OOP sogenannte "Traits". Da könnt ihr ja selbst mal googlen. Scheint ne nette Hilfe zu sein aber ein richtiges Anwendungsbeispiel dafür finde ich noch nicht.

MFG BlackY =)



Dem schließe ich mich an.

Traits sind nur Methoden- und Eigenschaftensammlungen und können am besetn da verwendet werden, wo zB bei Interfaces konkrete Implementierungen sich wiederholen und dieser doppelte Code sich nicht durch Vererbung auflösen lässt.


 

chrwhm
Verfasst am: 17.10.2013 um: 15:35 Uhr
 
Globaler Moderator
0
Beiträge: 6088
SPAM:
0% Spam
Mahlzeit,

aus Programmierer-Sicht kann ich das auch nur empfehlen ;-)
Haben bei uns bei der Umstellung allerdings festgestellt, dass es hier und da Änderungsbedarf bei alten Scripten gibt. Ich vermute deshalb, dass da noch eine Welle der Probleme auf das Forum zu rollt. Vielleicht wär ein Newsletter dazu auch noch ganz gut ;-)

lg



www.laptop-kaffee.de

"Normalised data is for sissies."
(Cal Henderson, chief software architect of flickr)

 

consider
Verfasst am: 17.10.2013 um: 15:37 Uhr
 
Dr. CwCity.de
Community God
Beiträge: 7217
SPAM:
0% Spam
Jep, ich warte auch auf die ersten "deprecated" Warnmeldungen. :)

 

Ratgeber
Verfasst am: 17.10.2013 um: 17:30 Uhr
 
Dr. CwCity.de
Community God
Beiträge: 10010
SPAM:
0% Spam
  
Zitat von consider

Jep, ich warte auch auf die ersten "deprecated" Warnmeldungen. :)


Damit rechne ich auch.

Rechtzeitige Vorwarnung, wann das Updaten beginnt, wäre mir schon recht lieb.


 
Ratgeber---Forum.de ---- Partnerseiten ------ Halle der Ehre ----- zum Forum ---- Ratgeber---Forum.Net ----- Das Ende des Internets
----> Interessante andere Seiten --> Toromino.de 


 

Freggle
Verfasst am: 17.10.2013 um: 18:56 Uhr
 
Cw Supporter
Cw Supporter
Beiträge: 11927
SPAM:
0% Spam
  
Zitat von Ratgeber
Rechtzeitige Vorwarnung, wann das Updaten beginnt, wäre mir schon recht lieb.

Wurde ja hiermit getan, kannst dich also schon darum kümmern, dass es nachher keine Probleme gibt.


 
 

chrwhm
Verfasst am: 17.10.2013 um: 20:05 Uhr
 
Globaler Moderator
0
Beiträge: 6088
SPAM:
0% Spam
Mahlzeit,

möglicherweise nicht nur deprecated - sondern auch "does not exist" wie z.b. bei session_register()... Hatte demletzt auch ein Script was sich nicht installieren lassen wollte, weil es irgendeine veraltete PHP-Option nicht auf "true" vorgefunden hat; blöd nur, dass es diese Einstellung gar nicht mehr gab...

lg



www.laptop-kaffee.de

"Normalised data is for sissies."
(Cal Henderson, chief software architect of flickr)

 

consider
Verfasst am: 17.10.2013 um: 22:44 Uhr
 
Dr. CwCity.de
Community God
Beiträge: 7217
SPAM:
0% Spam
Jep, Funktionen die seit 5.3 deprecated sind werden dann mit 5.4 entfernt. Ist ja üblicher Werdegangm, wenn ich das richtig verstanden habe. Schlecht für die, die die Warnungen einfach nur mittels @ unterdrückt haben. Die ham jetzt richtig Ârger.

 

blackphantom
Verfasst am: 17.10.2013 um: 22:54 Uhr
 
Dr. CwCity.de
Community God
Beiträge: 3017
SPAM:
0% Spam
  
Zitat von consider
Schlecht für die, die die Warnungen einfach nur mittels @ unterdrückt haben. Die ham jetzt richtig Ârger.


Will ja nicht böse klingen aber das sind se selbst schuld.
Aber es werden mit Sicherheit tausende 0815- / Uraltscripte nicht mehr oder nicht mehr richtig funktionieren. Schön das endlich mal aufgeräumt wird.

Eine neue Funktion die hinzugekommen ist nennt sich übrigens: http_response_code(). Das Teil gibt dir jetzt den HTTP-Statuscode der aktuellen Anfrage zurück. Das ging vorher zwar auch anders aber jetzt ist es direkt in ner Funktion. Finde ich persönlich super. :)

MFG BlackY =)

 

 
Seiten: 1, 2, 3 >>

Folgende User sind hier gerade aktiv:
-

ANZEIGE