CwCity Board >>> Hard- & Software >>> Software >>> [Excel] Prüfen ob ein Zeichen in einer Zelle vorkommt
[Excel] Prüfen ob ein Zeichen in einer Zelle vorkommt

Seiten: 1
ck4ever
Verfasst am: 24.09.2015 um: 13:54 Uhr
 
Cw Insider
Wirths Sammler
Beiträge: 155
SPAM:
1% Spam
Hey,

hab mal wieder eine Frage bezüglich Excel ^^

Ich habe eine Spalte wo ich feste Werte aber auch prozentuale Werte stehen habe. Und weil das noch nicht reicht, auch Texte. Sieht grob so aus:

1000
500
ja
nein
1 pro Monat
1%
2%
0,5%
usw.

Diese Werte sind immer unterschiedlich und ich füge diese von externer Quelle (copy und paste) in meine Datei ein. Ich möchte jetzt diese Spalte in ein anderes Tabellenblatt übernehmen, allerdings sollen die %-Zahlen umgerechnet werden.

Hab mir gedacht ich mache das mit einer WENN Abfrage wo geprüft wird ob ein % Zeichen enthalten ist, dann rechnen, ansonsten den Wert selbst übernehmen. Aber irgendwie klappt das nicht. Mein erster Entwurf sieht so aus, wobei ich jetzt nur suche ob ein % enthalten ist ohne den Wert dann umzurechnen, aber als Ergebnis bekomme ich immer nur "keins" angezeigt.

=WENN(ISTFEHLER(FINDEN("%";B1;1));"keins";" ;eins")

 



Freggle
Verfasst am: 24.09.2015 um: 16:22 Uhr
 
Cw Supporter
Cw Supporter
Beiträge: 11927
SPAM:
0% Spam
Den Prozentwert rechnet Excel automatisch um bzw. wandelt das Zellenformat in "Prozent" um. Das ist auch der Grund weshalb deine Funktion immer nur "keins" liefert, weil im Feld bereits 0,01/0,02/0,005 steht.
Würdest du vor deine Prozentzahl ein ' schreiben, dann wird es als Text erkannt und deine Funktion liefert "eins".


 
 

ck4ever
Verfasst am: 24.09.2015 um: 18:10 Uhr
 
Cw Insider
Wirths Sammler
Beiträge: 155
SPAM:
1% Spam
Achso, da es quasi wie ein Währungsymbol zwar angezeigt wird, aber eigentlich nicht in der Zelle vorkommt richtig? Dann gibts also keine Möglichkeit das ganze so umzusetzen wie ich das möchte?

Edit:
Oder doch, wenn ich statt "%" nach "," suche müsste es doch gehen. Ich versuchs gleich mal...




Letzte Änderung am: 24.09.2015 um: 18:13 Uhr durch: ck4ever
 

markush
Verfasst am: 24.09.2015 um: 20:27 Uhr
 
Dr. CwCity.de
Community God
Beiträge: 3832
SPAM:
0% Spam
Du möchtest regelmässig irgendwelche Daten von irgendwo her auslesen, aussortieren bzw. ordnen und dann irgendwo ausgeben. Da solltest du dir überlegen ob du dir nicht ein kleines Skript schreibst wo das alles übernimmt.

So wie in dem Beispiel:

www.cwcity.de/community/board/showt...

Der Link zu meinem Github Profil

Weitere Links:
--> ratgeber---forum.de (Danke für die Unterstützung) <--
 

ck4ever
Verfasst am: 24.09.2015 um: 23:58 Uhr
 
Cw Insider
Wirths Sammler
Beiträge: 155
SPAM:
1% Spam
Ach ne, das ist mir zu kompliziert zu lernen. In Excel fällt mir das ganze leichter weil es ne gewohnte Umgebung ist. Ich hab jetzt mittlerweile eine funktionierende Lösung gefunden die funktioniert :) Die erste Abfrage mit "1" musste ich einbauen, da die Formel von 1-99% passte, aber 100% immer nur "1" als Lösung auswarf. So sieht mein Fertiges Gestrüpp aus ^^

=WENN(AH132=1;Eingabedaten!E11;WENN(ISTFEHLER(FINDEN(","; AH132;1));AH132;AH132*Eingabedaten!E11))

 

 
Seiten: 1

Folgende User sind hier gerade aktiv:
-

ANZEIGE